Wednesday, 28 January 2009

My car has PMS! that's Pre-MOT Syndrome...

My car decided to throw a mojor strop on Monday. I never thought it was possible, but it is!
As I tried to start it, all I got was "machine gun noises". And after a few more tries, the battery went definitely dead...
Maria decided to be brave and while I was at work she released the cables but was unable to unscrew it from the car, as the bolt was really rusty. So as soon as I set foot in Sutton, I made a b-line to Halfords and bought the wonderful WD-40 and a socket set. It was already dark when I reached home, but we immediately started getting the battery out, taking it home and recharging it.
After 3 hours (that goes to show how shitty the battery must be now, to say it is completely recharged only after 3 hours!!), we took it back to the car and it finally started!! We immediately jumped inside and went for a drive for 90 minutes.

The car's MOT is in March and because it's nearing the 45,000 miles, it will also need a complete servicing at Rover. Could it have been Pre-MOT Syndrome????

5 comments:

Tuga em Londres said...

woow! For a moment I had to double check if I was actually in your blog or someone's elses. Big change from black to red. Red, blue, white and blue stars? Is it to celebrate Barack obama's victory?

living in london said...

gosto do novo aspecto do teu blog,esta giro.
acabaste por te render a mudanca!

Wask said...

eheheheheh...
a Maria achou que precisava de um revamp.. e este era o background menos "maricas" que havia :P

Afrika said...

Bemmm ja tou como a tuga em londres.
What a change! i like it . quanto ao carro, get a new one!

MS said...

Rover: Nuff said.

Enquanto fôr só a bateria...